Experteneinstellungen

Aus Freifunk Köln, Bonn und Umgebung
Wechseln zu: Navigation, Suche

< Firmware updaten         Übersicht         Optional: Pimp my Node >


Für diese Einstellungen wird ein SSH-Zugang zum Node benötigt. Der muss wie in Node konfigurieren beschrieben aktiviert werden. Außerdem wird ein SSH-Client auf dem Computer benötigt. Unter Windows kann dafür PuTTY PuTTY-Webseite verwendet werden.

SSH-Keys können mit PuTTYgen (ebenfalls unter PuTTY-Webseite) erzeugt und verwaltet werden (s. auch Google). Falls es Probleme mit der Einrichtung eines SSH-Keys gibt, ist es meist am einfachsten, einmal zu einem Freifunktreffen zu kommen, und sich dort helfen zu lassen.

SSH-Zugang einrichten

Es gibt zwei Möglichkeiten sich per SSH mit einem Freifunk-Knoten zu verbinden: Mit einem Passwort oder mit einem SSH-Key.

Wir empfohlen, sich mit SSH-Key zu verbinden. Da die Freifunk-Knoten im Internet direkt erreichbar sind, bieten Passwörter eine sehr große Angriffsoberfläche über Wörtebuchattacken und Ähnliches.

Mit SSH-Keys

Unter Linux sollte ein RSA-Key in ~/.ssh/id_rsa.pub liegen. Der kann mit

 cat ~/.ssh/id_rsa.pub

angezeigt werden. Falls kein Key vorhanden ist, kann mit

 ssh-keygen -t rsa -b 4096 -C "your_email@example.com"

einer generiert werden.

Dieser Key kann im Config-Menü eingetragen werden: TODO: Bild Config Menü

Mit Passwort

Zum ersten Ausprobieren oder falls das Nutzen eines SSH-Keys nicht möglich ist, kann man sich auch mit einem Passwort zu dem Node verbinden. Dazu wird einfach ein Passwort im Config-Menü eingetragen: TODO: Bild Config Menü

Per SSH zu Node verbinden

Die IP des Node kann zum Beispiel auf der Karte (https://map.kbu.freifunk.net/) ermittelt werden. Dann kann man sich zu dem Knoten per SSH verbinden:

 ssh root@<<<ip-adresse>>>

SSH unter Windows: PuTTY

PuTTY
PuTTY: Bei der ersten Verbindung muss die Identität des Servers bestätigt werden

Unter Windows kann man das Programm PuTTY (putty.exe) verwenden, um eine SSH-Verbindung aufzubauen. PuTTY kann man sich auf der PuTTY-Hompage herunterladen.

PuTTY kann auch mit SSH-Key-Authentifizierung benutzt werden. Dazu muss mit PuTTYGen (puttygen.exe) ein Key generiert werden. Dieser Key muss in Pageant (pageant.exe) geladen werden, bevor PuTTY gestartet wird. Beide Programme gibt es ebenfalls auf der PuTTY-Hompage. Dokumentation zu diesen Programmen finden sich auf der Pagenant-Dokumentation und der PuTTYGen-Dokumentation.

Standardkonfiguration via SSH vornehmen

Position für die Karte eintragen / ändern

Die Position auf der Karte wird in der /etc/config/gluon-node-info konfiguriert.

Die Änderungen erscheinen nach etwa 5 Minuten auf der Karte https://map.kbu.freifunk.net/.

Node von der Karte entfernen

Einfach im Abschnitt config location option share_location '0' setzen.

Node auf Karte eintragen / ändern

Dazu muss der folgende Abschnitt in der /etc/config/gluon-node-info eingefügt / geändert werden.

 config location
       option share_location '1'
       option latitude '50.7107'
       option longitude '7.1079'
       option altitude '72'

Die letze Angabe option altitude kann weggelassen werden, wenn man die genaue Höhe nicht weiß.

Kontaktangabe ändern

Dies wird durch den folgenden Abschnitt in der /etc/config/gluon-node-info geregelt:

 config owner
       option contact '<<<Email oder Telefonnummer>>>'

Privates WLAN hinzufügen

Der Node kann auch das lokale Heimnetzwerk über WLAN ausstrahlen. Das sollte dann aber auf jeden Fall mit einem Passwort absichern.

Dazu gibt man einfach in der /etc/config/wireless ganz am Ende noch an:

 config wifi-iface 'wan_radio0'
       option ifname 'wlan0'
       option network 'wan'
       option disabled '0'
       option device 'radio0'
       option mode 'ap'
       option ssid '<<<SSID>>>'
       option encryption 'psk2'
       option key '<<<Passwort>>>'

<<<SSID>>> und <<<Passwort>>> sollten natürlich durch den Namen des WLANs und durch das Passwort ersetzt werden.

Am Ende auf der Shell noch

 wifi

eingeben, damit die Netzwerkeinstellungen übernommen werden. Das neue WLAN sollte jetzt auftauchen und mit dem Heimnetzwerk verbinden.

Knoten über SSH Updaten

Dazu das Image per SCP auf den Knoten in das Verzeichnis /tmp/ schieben. Es es wichtig, dass das Image nach /tmp/ kopiert wird und nicht woanders hin. Dann in das Verzeichnis /tmp/ wechseln:

 cd /tmp/

Jetzt sollte überprüft werden, dass das Image ohne Fehler übertragen wurde. Es genügt dafür ein 'md5sum', aber 'sha256sum' ist besser:

 sha256sum  gluon-ffkbu-V2-v2018.2-FastD-tp-link-tl-wa860re-v1-sysupgrade.bin 

Das Update kann jetzt eingespielt werden. Dabei bleibt die Konfiguration bestehen.

 sysupgrade -v gluon-ffkbu-V2-v2018.2-FastD-tp-link-tl-wa860re-v1-sysupgrade.bin

Soll die Konfiguration dagegen wieder mit den Default-Einstellungen überschrieben werden, muss die Option '-n' angegeben werden:

 sysupgrade -vn gluon-ffkbu-V2-v2018.2-FastD-tp-link-tl-wa860re-v1-sysupgrade.bin

TP-Link WR 841 als Switch für Heimnetzwerk verwenden

Standardmäßig stellt der WR 841 über den blauen Port eine fastd-Meshverbindung über das Internet her und gibt aus den gelben Ports entweder Freifunknetz aus oder mesht mit anderen Nodes.

Man kann ihn aber auch dazu überreden, über die gelben Ports die fastd-Verbindung über das Internet aufzubauen und über den blauen Port Freifunk auszuspucken oder zu meshen. Die gelben Ports fungieren dann automatisch wie ein 4-Port Switch im Heimnetzwerk.

Dazu ändert man einfach in der /etc/config/network alle Auftreten von eth0 (gelbe Ports¹) durch eth1 (blauer Port) und umgekehrt. Das Ergebnis sollte dann in etwa so aussehen:

 config interface 'wan'
       option ifname 'eth0'
       ...
 config interface 'mesh_lan'
       option ifname 'eth1'
       ...
 config interface 'client_lan'
       option ifname 'eth1'
       ...

Der Router sollte jetzt einmal neugestartet werden.

¹ Ja, alle gelben Ports werden intern über ein einziges Interface angesprochen. In der Kiste steckt ein kleiner 5-Port-Switch, von dem 4 Ports nach draußen gehen (gelb) und einen zum Betriebssystem.


< Firmware updaten         Übersicht         Optional: Pimp my Node >